Node2Shell Vulnerability Triggers Urgent Patches Across Microsoft, Node.js, and Python
Share
A critical security vulnerability in Google’s Brotli data compression library has triggered a wave of emergency updates across the software industry. The flaw, tracked as CVE-2026-111497 and dubbed Node2Shell, affects a wide range of popular development environments including Node.js, .NET, and Python.
Brotli is widely used for data compression in web browsers and servers to improve loading speeds. The vulnerability is described as an out-of-bounds write bug within the Brotli decoder, impacting versions 1.0.3 through 1.2.0. Google has assigned the flaw a critical CVSS v4 score of 9.2.
According to the Node.js project, the issue arises when the decoder processes specially crafted input, which can push data beyond the boundaries of a designated memory buffer. This resulting memory corruption could allow an unauthenticated attacker to crash a process, leak sensitive memory contents, or execute arbitrary code on the target system.
OpenAI Researchers Identify Supply Chain Risk
The flaw was identified by members of OpenAI Codex Security during a red-teaming exercise. Researchers noted a significant delay between the initial fix in the Brotli source code and the official security disclosure.
While the root cause was addressed in the Brotli source code as early as February, it was not initially recognised as a security-critical vulnerability. This meant that many downstream projects continued to use the vulnerable code until the security implications were fully understood and disclosed this month.
OpenAI’s Patch the Planet initiative warned that any application passing attacker-controlled data to an affected Brotli decoder could be exposed. This risk extends to compressed HTTP request bodies and files fetched from untrusted servers.
Microsoft and Python Maintainers Release Fixes
Microsoft has released a series of updates to address the vulnerability across its ecosystem. The fixes cover .NET runtime versions 8.0.33, 9.0.22, and 10.0.14, as well as Visual Studio 2019, 2022, and 2026. PowerShell versions 7.4 through 7.6 have also been updated.
In the Python ecosystem, the vulnerable decoder is embedded in the popular PyPI packages “Brotli” and “brotlicffi.” Maintainers have released versions 1.2.1 and 1.2.1.0, respectively, to mitigate the risk.
Other major projects that rely on Brotli, including the Bun runtime, Envoy, and Istio, have also moved to release patches. However, several other projects that bundle their own copy of the Brotli decoder, such as 7-Zip-zstd and Apache Arrow, are still being tracked for potential exposure.
Exploitation Potential and Mitigation
Researchers at Imperva successfully demonstrated a proof-of-concept exploit achieving code execution on an official Node.js image for Linux ARM64. While the exploit was not successful on every attempt, it confirms the theoretical risk of remote code execution (RCE) in real-world environments.
There have been no confirmed reports of the Node2Shell vulnerability being exploited in the wild. However, Microsoft has categorised the exploitability assessment for .NET and Visual Studio as “Exploitation More Likely.”
To secure systems, administrators are advised to update to Brotli versions 1.0.10, 1.1.1, or 1.2.1. Because many applications bundle the library, simply updating the system-level library may not be sufficient. Organisations should rebuild container images using patched base images and restart affected services to ensure the vulnerable code is no longer in use.




Leave a Reply